ruby-processingのインストール

2013/08/06 23:18

rubyから2Dとか3Dを扱うruby-processingをインストールしてみました。
忘れないように備忘録です。

まずGitHubからruby-processingをクローンします。

git clone https://github.com/jashkenas/ruby-processing.git

クローンが終わった後にrakeを実行しますがwgetが必要だったのでインストールします。

sudo port install wget

wgetのインストールが終わったらrakeコマンドでセットアップを行います。

cd ruby-processing
rake

私の環境では下記の通りテストがエラーになってしまいました。

  1) Failure:
  test_opengl_version(Rp5Test) [test/rp5_test.rb:116]:
  Graphics capability 2.1 INTEL-8.12.47 may be sub-optimal

エラーメッセージを見るとOpenGLが3以上というテストにひっかかっているけど私の環境は問題ないのでテスト結果は無視しました。

ローカルにgemファイルがあるのでそれをインストール。

gem install ruby-processing-2.1.1.gem

これで一連のインストールは完了なので実際に動かしてみます。

rp5 run samples/contributed/tree.rb 

これでうまく木が動く絵が表示されれば動作確認OKです。